https! Finally!

Get up to date with the goings on of the forum

Moderator: Jake

1hellsbells99
Occasional poster
Posts: 29
Joined: Tue Jul 07, 2015 3:03 am

Re: https! Finally!

Post by 1hellsbells99 » Fri Feb 15, 2019 4:48 am

I had a problem signing in as well. I couldn't log on or request password. came to site through google instead of old bookmark and that fixed the problem.

User avatar
Rommeltje
The man in charge
Posts: 10399
Joined: Sat Nov 20, 2010 10:14 pm
Location: Amsterdam
Contact:

Re: https! Finally!

Post by Rommeltje » Fri Feb 15, 2019 1:17 pm

Yeah, I'm thinking it's probably just that. If you've bookmarked the site, or if it's still in your history, you're linked to the non-https version of the site.

If you type in "wwgfa.info", or "www.wwgfa.info", or "http://www.wwgfa.info", you're automatically redirected to "https://www.wwgfa.info/forum". But an existing bookmark will send you directly to "http://www.wwgfa.info/forum" (so without the extra s), and circumvent the redirect.

Unfortunately, this also means that redirects within the forum (the ones that were posted before the switch to https), will link to a http url, and you will be prompted to log in again. New links won't have that problem, though. Just keep in mind that that might happen.

User avatar
Max
Senior member
Posts: 302
Joined: Sun Jul 13, 2014 5:00 pm

Re: https! Finally!

Post by Max » Fri Feb 15, 2019 5:51 pm

Had also the login issue:

solution for me was using the HTTPS Link Rommeltje provided above. Using just www.wwgfa.info didn´t work for me.

Using the newest version of Firefox

User avatar
SexySurgical
Rommeltje's Deputy
Posts: 8236
Joined: Wed Nov 24, 2010 1:04 am
Location: Dutchieland
Contact:

Re: https! Finally!

Post by SexySurgical » Fri Feb 15, 2019 6:39 pm

Ah I see. When typing in wwgfa.info, one is redirected by the splash page to httpS://www.wwgfa.info/forum/
But when typing www.wwgfa.info/forum/, it *staYs on unencrypted, no SSL.

Max wrote:
Fri Feb 15, 2019 5:51 pm
Had also the login issue:

solution for me was using the HTTPS Link Rommeltje provided above. Using just www.wwgfa.info didn´t work for me.

Using the newest version of Firefox
tech ramble:
The former is a HTML/JavaScript redirect, the latter should be a phpBB or .htaccess redirect to the same page, now w/ httpS prefix. Probably a setting in forum admin.
Last edited by SexySurgical on Mon Feb 18, 2019 7:58 pm, edited 1 time in total.
Reason: *staYs
compose intricate posts somewhere else to not sorta "memory hole" them (when losing connection after hitting submit).

User avatar
sexcuir
Regular poster
Posts: 66
Joined: Wed Mar 30, 2011 10:08 am
Contact:

Re: https! Finally!

Post by sexcuir » Mon Feb 18, 2019 4:30 pm

8D everything perfect congs/rommu

User avatar
Rommeltje
The man in charge
Posts: 10399
Joined: Sat Nov 20, 2010 10:14 pm
Location: Amsterdam
Contact:

Re: https! Finally!

Post by Rommeltje » Mon Feb 18, 2019 11:18 pm

sexcuir wrote:
Mon Feb 18, 2019 4:30 pm
8D everything perfect congs/rommu
Good, thanks! :D

Also, did you slip and fall on your keyboard? :susp: :tongue:

7981878523
Occasional poster
Posts: 6
Joined: Wed Jan 30, 2019 12:53 am

Re: https! Finally!

Post by 7981878523 » Tue Feb 19, 2019 11:42 am

Thanks. On the other hand, if you use Firefox or Chrome, you could try installing HTTPS Everywhere, it will redirect any HTTP connection to the HTTPS version if available, blocking any insecure (non-encrypted) request to the servers.
https://www.eff.org/https-everywhere

Post Reply